Results 1 to 9 of 9

Thread: Linux Build

  1. #1

    Linux Build

    We've got a Linux build put together for those that are interested. You can get it here:

    http://www2.wastelands-interactive.c...agic_linux.zip

    Please let us know how it works for you.
    Everybody needs friends! Aaron's Facebook Page

  2. #2
    I haven't had time to test it extensively, but it looks great so far. The only problem I've seen so far is that the standard mouse pointer remains visible in game, and the in-game pointer lags behind it slightly.

  3. #3
    Sorcerer of the Lesser Tower
    Join Date
    Oct 2013
    Posts
    83
    I also saw the double-pointer issue. The most glaring bug, though, was the button that said "Exit to Windows" : ) Other than that, it all seemed to play perfectly equivalently to the windows build. Good job!

    For reference, here's my uname -a
    Linux [hostname redacted] 3.10.7-gentoo-r1 #1 SMP Mon Oct 7 09:17:15 PDT 2013 x86_64 AMD Phenom(tm) II X2 550 Processor AuthenticAMD GNU/Linux

    and my lspci | grep VGA
    01:00.0 VGA compatible controller: NVIDIA Corporation GT200b [GeForce GTX 285] (rev a1)

    running x11-drivers/nvidia-drivers-319.60
    Last edited by Myk; 11-01-2013 at 09:43 PM.

  4. #4
    Thanks for testing it guys! We'll have to look into that double pointer issue.
    Everybody needs friends! Aaron's Facebook Page

  5. #5
    Moderator Asmodai's Avatar
    Join Date
    Feb 2013
    Location
    Fredericksburg, VA (USA)
    Posts
    794
    Quote Originally Posted by Myk View Post
    The most glaring bug, though, was the button that said "Exit to Windows"
    Why would that be a bug? Do you not run X Windows on Linux?

  6. #6
    Now that I've had a chance to test it more, it seems a bit sluggish in general. I think part of it is the lagging in-game pointer. I was worried that there was a more serious problem with the animations, but I think maybe they're taking as long as they are meant to. They just seem slow to me.

  7. #7
    They are a little slow.... We're going to work on it. And work on fixing the pointer bug
    Everybody needs friends! Aaron's Facebook Page

  8. #8
    Caster of the Inner Tower
    Join Date
    May 2013
    Location
    France
    Posts
    735
    Just tried the Linux build (sorry didn't have the time before).

    First my setup : Debian GNU/Linux Sid, 64-bits, with an old Core 2 E8400 and 4Gb of RAM using the Free Software Mesa stack on a Radeon 6850, glxinfo :
    OpenGL renderer string: Gallium 0.4 on AMD BARTS
    OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.2.2

    Feedback : overall it works very well. I have the glitch of the two mouse cursors, but the cursors move smoothly. I would like an option to display the framerate (so I can compare between 32-bits and 64-bits build, with the windows version using wine, ...), but it seems very reasonable at 1920x1080.

  9. #9
    Arcane Candidate
    Join Date
    Feb 2014
    Posts
    6
    The build link gives me 404, and i would love to test it :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
footer