Results 1 to 5 of 5

Thread: [B0006] - RESOLVED - Autoscouting no longer works in v1.2.4 (iOS)

  1. #1

    [B0006] - RESOLVED - Autoscouting no longer works in v1.2.4 (iOS)

    Lickzy reported this on TA, and I confirm the issue:
    In v1.2.4 on iOS, autoscouting no longer works. In all previous versions, it worked correctly.
    UPDATE/CORRECTION: Had the wrong version number. It's v1.2.4, not v1.2.3.

    Steps to reproduce:
    1) Start a new game.
    2) Summon a Magic Spirit.
    3) Move the Spirit out of your town.
    3a) OPTIONAL: Set any of your starting garrison units to autoscouting, to show that it affects other units as well.
    4) Select autoscouting for the Spirit.
    5) End turn.
    6) Note that the Spirit doesn't move, despite autoscouting showing up correctly as action for it.
    7) You should have 3 "open tasks": a) your town doesn't build anything b) you don't have any research ongoing c) town garrison is not set to "guard".
    8) Close the "open tasks", end turn after each. When you close the first two, autoscout still doesn't work. Only when you close them all, autoscout takes off.
    9) Remove your town from Housing, so it doesn't produce anything.
    10) End turn.
    11) Autoscouting fails again.
    12) Set town back to Housing, end turn: autoscout works.

    Also tested with a Sprite, as reported by Lickzy, same issue. So I assume it's a general problem and not tied to a specific unit, for example.

    Tested on iPad Air1, iOS 9.3.1 , not jailbroken.
    Last edited by MedievalNerd; 05-05-2016 at 03:25 AM.

  2. #2
    As I don't have any important saves to lose, I deleted/reinstalled and tried again.
    And I think I figured out what's going wrong:
    When you have any open tasks, e.g. no Research ongoing, or a town that doesn't build anything, Autoscout fails.
    Once you took care of those open tasks, and end the turn, autoscouting works correctly again.

    I think this is different from earlier versions, but not 100% sure. Could you please check and confirm?

    Also, I updated the repro steps in the first post.

    UPDATE 2: Works as designed?
    See Mintdragon's comment on TA:
    Last edited by Nullzone; 04-19-2016 at 04:15 PM.

  3. #3
    Working on it

  4. #4
    Thanks, Wojciech!

  5. #5
    Has been fixed

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts