Hey DT, I was able to set it to run as admin permanently by right clicking on the .exe and going to Properties>Compatability>Run as admin (checkbox).

I had only set the setup.exe to run as admin originally, and then I had set the shortcut to run as admin. :-P

It works now, thanks!